1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sprays not working.

Discussion in 'Team Fortress 2' started by Cappabitch, May 27, 2009.

  1. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    Recently I tried to get a friend running TF2 better than he can right now (bad system, he gets about 2-3 fps), so I got into testing autoexec configuration files to absolutely destroy graphics, but beef FPS. I got the idea from a topic in About No Heroes concerning legal configs.

    Anyways, after playing around (and noticing that one particular one gives me about 140 FPS, but has a funny side effect of making 2fort look like a Cave; every wall, ceiling, ground, and water texture were completely black. Only objects like items, boxes, hay, etc. were visible. Surreal.), I decided, eh, enough of this, and set the launch option -autoconfig to restore my usual graphic settings. Only one problem: Sprays don''t show up. -Anywhere-. Any server.

    I knew one autoexec file I used disallowed disabled sprays, using the console code r_spray_lifetime "0.1", but I had long since changed that, and even with everything back to norm now and not using autoexec files, I still don't have any sprays :(

    Anyone have a fix that doesn't involve reinstalling TF2?
     
  2. Proven

    Proven Community Veteran

    Joined:
    Dec 31, 2008
    Messages:
    6,814
    Likes Received:
    459
    I've been there, and unless someone has some magic mojo you'll save yourself a lot of time by just reinstalling.
     
  3. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    Rageee. And I -just- had my TF2 where I get awesome FPS -and- graphic quality on 1024x720...
     
  4. Engrishman

    Engrishman Server Admin
    VIP

    Joined:
    Sep 17, 2008
    Messages:
    1,618
    Likes Received:
    4

    That's kinda why you need to back up your TF2 before changing something drastic. Last I checked there was a built-in "back up my steam games" feature offered by the default program.
     
  5. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    Oh well. I'll probably re-download overnight (I wouldn't mind playing some more later).
     
  6. bclose

    bclose Senior Admins
    Senior Admin

    Joined:
    Aug 17, 2008
    Messages:
    9,721
    Likes Received:
    1,134
    You could look around for a clean copy of the autoexec.cfg and use that.
     
  7. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    autoexec was actually a file I had to make myself and copypasta a list of settings. I figured deleting it/launch option -autoconfig would restore tf2 to default, which it did completely; -except- for Sprays, which still will not show up.

    Normally not a big deal, but I've always liked sprays, and a tf2 without them just feels meh >_>
     
  8. GlaDOS V1.09

    GlaDOS V1.09 New Member

    Joined:
    Sep 7, 2008
    Messages:
    3,624
    Likes Received:
    2
    I had that problem too. check the game settings and see if u have a limit on decals. That will also affect sprays. And check in the settings to see if sprays are turned off. Delete the old autoexec, because it might be interfering with the regular settings, thats what I had to do.
     
  9. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    I knew sparys weren't disabled, but I haven't checked multiplayer decals. I think 200 is default, am I right?
     
  10. GlaDOS V1.09

    GlaDOS V1.09 New Member

    Joined:
    Sep 7, 2008
    Messages:
    3,624
    Likes Received:
    2
    it is I think. I usually set it much higher tho to make sure lol!
     
  11. Guest

    I've run into similar problems where my sprays won't display but tell me I had sprayed one.

    It seems to happen more times than one when changing maps. All I have to do is disconnect and return and they start showing up.

    Definitely check your decal limit though. Also, are your sprays in the right format? I think the max is 256 x 256 and like 120-150 mb? Something like that.
     
  12. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    The result, the multiplayer decal limit. Because autoconfig doesn't effect my own multiplayer settings, it wasn't working.
     
  13. Proven

    Proven Community Veteran

    Joined:
    Dec 31, 2008
    Messages:
    6,814
    Likes Received:
    459
    So, you fixed it? or no. I am confused by your post sir. :???:
     
  14. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    The reason sprays weren't working is because the autoexec changed my multiplayer decal to 0, which was saved to my Steam profile/cloud/whatever, which I had to manually change back to 200.
     
  15. GlaDOS V1.09

    GlaDOS V1.09 New Member

    Joined:
    Sep 7, 2008
    Messages:
    3,624
    Likes Received:
    2
    Glad I could help then :D
     
  16. King

    King Guest

    I am wondering if you would get the same effect in Warpath? If not, can you share that config please? :grin:
     
  17. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    I'll need to track it down, but I'll give the one that gave me the less graphic rape (with the occasional side-effect of a pitch-black 2fort, although that only happened on one resolution).
     
  18. Cappabitch

    Cappabitch New Member

    Joined:
    Nov 27, 2008
    Messages:
    2,566
    Likes Received:
    21
    I totally didn't forget about this.

    no sir.

    http://www.lemmy-forum.net/random/tf2.txt You can give that a try, King (or anyone else who are having less-than-acceptable framerates). Copy that into notepad, 'save as', file type 'all files', and save 'autoexec.cfg' into your steam/steamapps/account-name/Team Fortress 2/tf/config folder. Hopefully you avoid the black-texture issue I had.

    To undo, just delete the file and run TF2 with the launch option -autoconfig once (be sure to change your multiplayer decal limit. Don't be a moron like me~)

    EDIT: 'mat_queue_mode "-1"' change that -1 to 2 if you have a dual-core. That should increase your framerate with the autoconfig. I was getting 140 fps on 1680x1024. All you need ideally is about 60, since that's basically as many frames as the human eye can see per second.